Saturday, July 23, 2016

Security Update: php, gimp, bind

Three security updates were releases in the last two days:
  • php: Upgraded to 5.6.24 for Slackware 14.0 and newer
  • gimp: Upgraded to 2.8.18 for Slackware 14.0 and newer
  • bind: Upgraded to 9.9.9_P2 (13-14.1) and 9.10.4_P2 (14.2 and newer)
What's interesting is that Pat also upgrade packages in current branch:
  • tmux: upgraded to 2.2.x (moved from testing)
  • guile: Upgraded to 2.0.12
  • freetype: Upgraded to 2.6.5
  • libgcrypt: Upgraded to 1.7.2
  • network-script: Rebuilt to use -L to dhcpcd to avoid Zeroconf
  • dialog: Upgraded to 1.3_20160424
  • kmod: Upgraded to 23
  • lvm2: Upgraded to 2.02.161
  • git: Upgraded to 2.9.2
  • desktop-file-utils: Upgraded to 0.23
  • harfbuzz: Upgraded to 1.3.0
  • httpd: Upgraded to 2.4.23
  • lftp: Upgraded to 4.7.3
  • links: Upgraded to 2.13
  • xf86-video-openchrome: Upgraded to 0.5.0
  • xkeyboard-config: Upgraded to 2.18
  • xorg-server: Upgraded to 1.18.4
I guess those are considered safe upgrade since they are all compiled against the same toolchain as used in Slackware 14.2.