Friday, October 30, 2015

Big Batch Update

Pat released a big batch update this morning along with three security vulnerabilities for all supported Slackware releases back to Slackware 13.0. They are Jasper, NTP, and CURL packages. Please upgrade them if you are still using the old version.

Meanwhile in current there are a lot of new exciting stuff:
  • automake-1.15
  • kernel 4.1.12
  • cmake-3.3.2
  • git-2.6.2
  • make-4.1
  • perl 5.22
  • subversion-1.9.2
  • kdelibs 4.14.13
  • GTK+3-3.18
  • freetype 2.6.1
  • gdk_pixbuf2-2.32.1
  • glib2-2.46.1
  • gstreamer-1.6.0 + gst-plugins-{base,good}-1.6.0
  • gvfs-1.26.1
  • libtiff-4.0.5
  • poppler-0.37.0
  • qca-2.0.3
  • httpd-2.4.17
  • samba 4.3.1
  • vsftpd-3.0.3
  • mesa-11.0.4
  • pixman-0.33.4
  • imagemagic-6.9.2_4
  • xorg-server-1.17.3
  • firefox-41.0.2
  • lots of many other upgraded packages
  • and many new packages:
    • scons
    • ConsoleKit2 (replacing ConsoleKit)
    • gsl
    • libvisio
    • libwpg
    • pygobject3
    • serf
    • libssh2
Make sure to install new packages first before upgrading (especially ConsoleKit2) and don't forget to remove the unused packages (ConsoleKit).

I'm looking forward to see RC1 soon :)