Saturday, August 22, 2015

Security Update: gnutls

One security update was released this weekend and it was gnutls. This update applies to 14.0, 14.1, and current. For those living in 14.0, please make sure to install a new package first: nettle.

current is now progressing very well. Pat added and upgraded lots of packages in this batch. Here are the highlights:
  • Linux Kernel 4.1
  • glibc 2.22
  • gcc 4.9.3
  • ruby 2.2.3
  • gtk+3 3.16.6
  • gnutls 3.4.4
  • samba 4.2.3
  • libdrm 2.4.64
  • mesa 10.6.4
  • xorg 1.17.2
This surely interesting, but don't blindly upgrade. There are some newly added and removed packages in this batch, so please read the changelog carefully and take some notes on those packages.

If you are using proprietary blog drivers from NVidia/ATI, please make sure it's compatible with Linux Kernel 4.1 already.

Have fun testing new current :)