Sunday, November 16, 2014

Bad News for DigiKam Users

I may have a bad news for DigiKam users that are using Slackware-Current. DigiKam 4.5.0 has been released and i have pushed the updates to SlackBuilds project. This package works well under Slackware 14.1 stable, but unfortunately this may not work if you are using -current under a certain configuration.

If you have upgraded to the latest KDE 4.14.3 and KDE framework 5 along with Plasma 5 provided by Eric Hameleers, then you may not be able to use digiKam properly. I have tried many combinations, but still it ended with a segfault or build failure.

The possible solution is basically to upgrade exiv2 to 0.24 and have libkexiv2 in KDE 4.14.3 recompiled against exiv2 and then you can have a working digiKam.I have discussed it with digiKam maintainer and we believe this is the reason why it failed on my machine.

If you can build and run it properly without having to upgrade exiv2 and recompile KDE 4.14.3, then i will gladly hear your input on this issue.