Saturday, January 28, 2012

Updated Google Earth Stucked at LSB 4.0

There's a new Google Earth release and it's now 6.2. Unfortunately, the same version is not available in Linux and the latest one in Linux is at 6.0.3.2197. I once covered on how to install Google Earth on Slackware and it's working fine up to Version 6.0.2.2074.

Today, i downloaded the latest version and i saw an update there : 6.0.3.2197. I tried to reproduce the same steps i have been using to perform the installation of Google Earth in Linux, but this time, it failed me.
/GoogleEarthLinux.bin --target /tmp/ge
Creating directory /tmp/ge
Verifying archive integrity... All good.
Uncompressing Google Earth for GNU/Linux 6.0.3.2197.............................................................................................
This version of Google Earth requires LSB 4.0 support which you
do not seem to have.
./setup.sh: line 285: [: missing `]'
Unknown id: yum install redhat-lsb
I/O error : No such file or directory
setup.data/setup.xml:1: parser error : Document is empty

^
setup.data/setup.xml:1: parser error : Start tag expected, '<' not found

^
./setup.sh: line 158: 28089 Segmentation fault      "$setup" "$@"
I'm really sure that it was working in the previous version, but unfortunately, it's likely that Google changed it's requirement to have LSB 4.0 as the base