Sunday, November 30, 2008

Security Update: Ruby

Some small updates has been released on -Current, while there's one security update for previous version which is for Ruby. Here's the latest -Current changelog:
Sat Nov 29 14:21:53 CST 2008
a/lilo-22.8-i486-14.tgz: Fixed typo in liloconfig.

a/udev-130-i486-2.tgz: Rebuilt including a new /etc/modprobe.d/uhci-hci to make sure that the ehci-hcd module is always loaded before uhci-hci.

ap/lsscsi-0.21-i486-1.tgz: Upgraded to lsscsi-0.21.
Thanks to Darrell Anderson for pointing me to the new URL.

ap/mc-4.6.1_20070623p14-i486-2.tgz: Patched to fix a bug where moving or copying a file could cause mc to crash. Thanks to David Somero for the patch.

d/ruby-1.8.7_p72-i486-2.tgz: Recompiled with a patch to fix short name constants. Thanks to Marco Bonetti for pointing out the problem.

n/bridge-utils-1.2-i486-2.tgz: Patched to fix a corner case where brctl does not work if the name of the bridge is "bridge".

xap/audacious-plugins-1.5.1-i486-4.tgz: Patched to fix amidi-plug plugin.
Thanks to Giacomo Lozito.