Wednesday, September 11, 2013

xcb-util Upgrade Requires Some MSB Packages to be Rebuilt

If you are using MSB from GIT and also running on top of Slackware-Current, you might experience some problems after running the latest batch of update from Slackware-Current per September 9. This happened due to xcb-util was upgraded and they have bumped the shared library version. This will break several packages on MSB since they are built against that library.

The good news is that you only need to recompile some of the broken packages and you are all good. Here are the packages needed to be rebuilt :
  • base/mate-file-manager
  • base/mate-control-center
  • extra/mate-image-viewer