Friday, June 7, 2013

Big Update on Current: KDE 4.10.4 and Perl 5.18

Pat has indeed released a big update today by merging KDE 4.10.4 and Perl 5.18 on Slackware-Current branch. KDE 4.10.4 was already expected, but moving on to Perl 5.18.0 is something big since three months ago, Pat decided to take Perl 5.16.0 and now, Perl 5.18.0 gets included as well. This of course, requires some rebuilt on packages that relies on Perl, such as:
  • linuxdoc-tools
  • libproxy
  • pilot-links
  • irssi
  • net-snmp
  • obexftp
  • samba
  • pidgin
  • xchat
Other packages that gets a bump is git (1.8.3), subversion (1.7.10), swig (2.0.10), icu4c (5.1.2), libical (1.0), and imagemagick (6.8.5_9). Orage is also rebuilt against new libical.

I wonder if Pat wanted to include Python 3.3 branch on testing/ someday? It's not backward compatible as in Perl, but it's something unevitable. Someday, all applications should be moving on to Python 3.3 and i think it's better to have it ready on testing/ early on rather than late. For now, people who wanted to test Python 3.3 would have to go to SlackBuild Project and build it manually (or use sbopkg for that).